View Issue Details

IDProjectCategoryView StatusLast Update
0004807RunnerFunctionsPublic2018-10-30 12:15
ReportervanishAssigned ToFritz 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformOSiOSOS Version
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0004807: Functions: keyboard_key_press() not working on iOS [and Android in recent GMS2]
DescriptionSeems this doesn't work on iOS.

Would like to be able to use these in combination with device_... as they would then provide a better solution than the virtual keys, given those have some limitations.
Tagsandroid, ios, Keyboard, Runner
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In2.2.1.269

Activities

Elminster

2013-02-02 14:54

Updater   ~0016301

Kinda need this on our project... Any progress?

Russell Kay

2013-02-04 21:39

Manager   ~0016428

Give me a test project and I will take a look - this is not something we use frequently and does not seem to make much sense in an iOS environment but an example speaks volumes on what you are intending to do.

vanish

2013-03-27 01:44

Updater   ~0019242

Hi Russell, I can't think of a way to structure a test project when this function doesn't exist currently. It was a long time ago when I filed this report, and I can't remember what was lacking about virtual keys (perhaps the fact they have to be square).

Essentially, the reason I *think* I requested this function work in iOS, is it would provide a more flexible system for users to make their own virtual keys (a contrived example would be a circular collision object which sends a key press on touch), removing the need to rely on the built in virtual key system.

This is useful for the same reason virtual keys are useful in cross platform development. You can create a different input device per platform, but have the inputs read from the same key presses and processed into actions.

Neil Wicker

2014-06-16 17:36

Updater   ~0029791

This has been fixed for Android but still seems to be a problem with iOS using 1.3.1354. I've attached a sample project from another bug report - the square should move down and then along by itself at the start using keyboard_key_press, but remains still on iOS. Test on windows to see desired result.

Neil Wicker

2014-06-16 17:37

Updater  

keyboard_key_press.gmz (2,872,253 bytes)

Russell Kay

2018-05-09 15:51

Manager   ~0059307

this is still an issue, I think it is further complicated with the virtual keyboard stuff on iOS I can get it mostly working but the key does not stay down... I suspect VK work has banjaxed Android as well

Fritz

2018-08-24 15:59

Manager   ~0061376

android fix on 1c984245d5b783493ab79b75e71cf878d7e80ddb

Dan

2018-09-02 22:58

Adminstrator   ~0061457

Note that iOS AND Android have had fixes here - both need verifying.