View Issue Details

IDProjectCategoryView StatusLast Update
00317202.x IDE BugsCode EditorPublic2020-07-13 15:09
ReporterYellowAfterlifeAssigned ToRussell Kay 
PriorityLowSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionUnable To Reproduce 
PlatformOSWindows 10 ProOS Version>=18362
Product Version 
Target VersionFixed in Version 
Summary0031720: [2.3] Opening a specific code snippet hard crashes the IDE
DescriptionI was wondering if you could do this and I guess this is a "no"
function A(a) constructor {
    self.a = a;
}
function B() : A(argument_count > 0 ? argument[0] : "oh no") constructor {
    //
}
function scr_a_bug(){
    var b = new B(4);
    show_debug_message(b.a);
}
Steps To ReproduceOpen the project
Open scr_a_bug
There it goes
TagsCodeEditor
2.x IDE Found In9.2.1.2218
2.x Runtime Found In9.9.1.1793
2.x IDE Verified In
2.x Runtime Verified In

Activities

YellowAfterlife

2020-05-26 14:30

Developer  

a_bug23.zip (12,083 bytes)

Russell Kay

2020-06-24 15:42

Manager   ~0065623

Unable to reproduce in IDE v9.2.1.2254 Runtime v9.9.1.1825