View Issue Details

IDProjectCategoryView StatusLast Update
0031694RunnerWindows (YYC)Public2020-04-03 12:45
ReporterPatrick RocheAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
PlatformWindowsOS10OS Version
Product Version2.2.5 
Target VersionFixed in Version 
Summary0031694: YYC: Difference in behaviour between YYC and VM
DescriptionUser has reported a difference in behaviour between VM and YYC when casting to an INT. The attached project, when run in VM shows a circle in the bottom right moving to a circle in the top left. When run in YYC, the bottom right circle does not move.

Steps To Reproduce1 - Launch attached project in VM for Windows
2 - Launch attached project in YYC for Windows
3 - Notice differences
Additional Information' var d = move/move_sp; ' doesn't work but ' var d = ( (move*1.0)/(move_sp*1.0)); ' does work.
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In IDE v2.2.5.481 Runtime v2.2.5.378
2.x Runtime Verified In

Activities

Patrick Roche

2020-04-02 11:27

Adminstrator  

VM_YYC_Difference.yyz (22,385 bytes)

Russell Kay

2020-04-03 12:25

Manager   ~0065577

Looks like the problem is with irandom rather than the /

Russell Kay

2020-04-03 12:45

Manager   ~0065578

Fixed in gitlab - issue was that irandom returned an int64 and not a double, changed to be the same as VM now so it is a double