View Issue Details

IDProjectCategoryView StatusLast Update
0031684DocumentationManual ContentPublic2020-04-02 10:14
ReporterDanAssigned ToMark Alexander 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.2 
Target VersionFixed in Version 
Summary0031684: Manual Content: ds_priority_delete_...() pages state that items of equal priority are returned in FIFO order
Descriptionds_priority_delete_min/max pages both state that: "If more than one value has the same priority, the one that was added to the priority queue first will be the one to get removed...". This is not the case and as per comments from this issue: https://bugs.yoyogames.com/view.php?id=26111 it is not intended to work this way and entries with the same priority have no guaranteed order.

We previously fixed the ...find_min/max pages due to this, so copy the wording from those pages...



Steps To Reproduce1. Open help documentation
2. Navigate to the pages ds_priority_delete_min and ds_priority_delete_max
3. Observe issues in the description
Repro: 100%
TagsNo tags attached.

Relationships

related to 0030637 ClosedMark Alexander Documentation: ds_priority_find_xxx documentation states that items of equal priority are returned in FIFO order