View Issue Details

IDProjectCategoryView StatusLast Update
0031665RunnerNetworkingPublic2020-03-27 14:51
ReporterPatrick RocheAssigned ToFritz 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionFixed 
PlatformWindowsOSWindows 10OS Version
Product Version2.2.5 
Target Version2.3.0Fixed in Version 
Summary0031665: Networking: Crash after finishing Async Network event
DescriptionUser project is encountering a 100% crash when running and waiting roughly 5 seconds.

No logs are available for this issue. I've added debugging to this project in the form of 'show_debug_message("###I HIT THE END OF ALARM 0###")' messages. A destroy_instance was moved out of the async network event in the off chance that it was destroying something as it was being created due to async nature. Destroy_instance was moved to step.

Steps To Reproduce1 - Launch project in 2.2.5 IDE
2 - Run project
3 - Notice debug information showing where game crashes
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In IDE v2.2.5.481 Runtime v2.2.5.378
2.x Runtime Verified In

Activities

Patrick Roche

2020-03-12 12:01

Adminstrator   ~0065502

Project attached

networkbug (1).yyz (876,347 bytes)

Fritz

2020-03-13 12:01

Manager   ~0065505

This is fixed in blue,