View Issue Details

IDProjectCategoryView StatusLast Update
0031658RunnerFontPublic2020-03-27 14:50
ReporterPatrick RocheAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS Version
Product Version2.2.5 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031658: Font: draw_text_ext_transformed_colour() does not draw text if the string begins with "W"
Descriptiondraw_text_ext_transformed_colour is not drawing text if the string begins with letter W. In the attached example, obj_help attempts to use draw_text_ext_transformed_colour to draw 'When' on screen. It will also attempt to draw 'Then' on screen. "Then" is successfully drawn, "When" is not.

This seems to be related to using draw_set_font(font0); as when draw_set_font(font0); is removed this issue does not happen.
Steps To Reproduce1 - Launch attached project
2 - Open the Draw GUI event of obj_help
3 - Run project
4 - Notice "When" is not drawn
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.5.378
2.x Runtime Verified In

Activities

Patrick Roche

2020-03-06 10:47

Adminstrator  

wexample.yyz (35,306 bytes)

Russell Kay

2020-03-06 17:21

Manager   ~0065453

I have added a fix for this in gitlab - 4e52636fd4568a34c1b5d5bc2228c4e93f0a30e5

Fritz wanted it to be a message spam with callstack

Russell Kay

2020-03-09 11:40

Manager   ~0065456

Fixed in gitlab

Patrick Roche

2020-03-26 17:07

Adminstrator   ~0065547

WArnings are now given to user. Marking as fixed in IDE v23.1.1.129 Runtime v23.1.1.111

Dan

2020-03-27 14:50

Adminstrator   ~0065561

CB5