View Issue Details

IDProjectCategoryView StatusLast Update
0031656RunnerFunctionsPublic2020-05-28 16:15
ReporterScott DunbarAssigned ToFritz 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionUnable To Reproduce 
Product Version2.2.5 
Target VersionFixed in Version 
Summary0031656: Functions: instance_deactivate_object can cause all instances on a layer to become invisble
DescriptionIssue:
 calling instance_deactivate_object after setting the layer of the instance, is causing other objects and instances on that layer to become invisble

Expected
 Only the given instance or object should be impacted at all
Steps To Reproduce1. Import attached project
2. Run project
2a) observe positions of other instances
3. Right Click on any instance
4. Observe it has deactivated
5. Left click
6. Observe that sevaral other instances have disapeared
7. Move the mouse around and observe that collisions with invisible instances still occur (but not with the deactivated instance - this is correct)
8. right-click again to bring everything back
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.5.378
2.x Runtime Verified In

Activities

Scott Dunbar

2020-03-04 16:07

Adminstrator  

activated_instances_turn_invisible.yyz (28,495 bytes)

Fritz

2020-05-28 16:15

Manager   ~0065620

Unable to reproduce in runtime 9.9.1.1802