View Issue Details

IDProjectCategoryView StatusLast Update
0031612RunnerFunctionsPublic2020-02-27 13:49
ReporterScott DunbarAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionDuplicate 
Product Version2.2.5 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031612: Functions: draw_set_color inside a with is not producing the same results between VM and YYC
DescriptionIssue:
 When running yyc, a draw_set_color inside a with statement using a variable in container object will not yield the correct result in YYC, it does work correctly in VM

Steps To Reproduce1. Import attached project
2. Build for VM
3. observe that both squares are a medium grey colour
4. Build for YYC
5. Observe that the left square is black


Additional InformationThe attached example has a variable definition set in the object_colorHolder object
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In v2.2.5.378
2.x Runtime Verified In

Relationships

duplicate of 0031569 ResolvedRussell Kay Windows YYC: draw_sprite_ext() won't draw anything if alpha in the colour value used 

Activities

Scott Dunbar

2020-02-10 11:07

Adminstrator  

TestGMColor.yyz (17,172 bytes)

Russell Kay

2020-02-17 14:07

Manager   ~0065366

Last edited: 2020-02-17 14:08

View 2 revisions

Fixed in gitlab - I had already fixed this before Fritz looked at it - it is a duplicate of this bug https://bugs.yoyogames.com/view.php?id=31569