View Issue Details

IDProjectCategoryView StatusLast Update
0031574RunnerPathsPublic2020-01-13 16:27
ReporterDanAssigned ToFritz 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.5 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031574: Paths: Using a custom camera view breaks some path...() and mp_grid...() functions, causes silent crash
DescriptionSomething about using a custom camera view generated at runtime breaks path_get_length() and similar mp_grid...() pathing functions and causes a silent crash. You can see this in the attached sample via a couple of repro cases given below.

However, if you simply comment-out the if() line in obj_Player's Step event, then this will stop any issues and you can uncomment the various bits of "problem code" and play the game just fine. This is because avoiding the need to press the C key also means you don't trigger obj_Camera's Step event code to destroy the current view and make a new one.

The original report was that "mp_grid_path Crashes when path exceeds 11 cell length".
Steps To Reproduce1. Run the attached sample for Windows.
2. Press C to enter "battle mode".
3. Press D to move to the right or S to move down.
4. Observe the game crashes immediately with no error message or output window logging.
Repro: 100%

1. Uncomment the draw_text() in oCutoutEnemyBasic's Draw event
1. Run the attached sample for Windows.
2. Press C to enter "battle mode".
4. Observe the game crashes immediately with no error message or output window logging.
Repro: 100%
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/165407
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.5.378
2.x Runtime Verified In

Activities

Dan

2020-01-06 18:07

Adminstrator  

Pit_People.yyz (124,226 bytes)
CustomCameraPathsCrash.png (128,798 bytes)
CustomCameraPathsCrash.png (128,798 bytes)