View Issue Details

IDProjectCategoryView StatusLast Update
0031566RunnerExtensionsPublic2020-01-13 16:28
ReporterPatrick RocheAssigned ToFritz 
PriorityMediumSeverityA - Crash/HangReproducibility<25%
Status ResolvedResolutionFixed 
PlatformAndroidOSOS Version
Product Version2.2.4 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031566: Google Play Services: Service sign-in sometimes returns error and can cause crash
DescriptionWhile using the YoYo Games Google Play extension ( https://marketplace.yoyogames.com/assets/2008/google-play-services ) some users are occasionally reporting the following error:

signal 11 (SIGSEGV), code 1 (SEGV_MAPERR)

#00 pc 000000000001d220 /system/lib64/libc.so (strlen+16)
#01 pc 000000000006648c /system/lib64/libc.so (strdup+20)
#02 pc 0000000000347c84 /data/app/com.**.**-0S3eexT7ZKNC3uLWnQf_wQ==/lib/arm64/libyoyo.so (Java_com_yoyogames_runner_RunnerJNILib_OnLoginSuccess+500)
#03 pc 00000000000446dc /data/app/com.**.**-0S3eexT7ZKNC3uLWnQf_wQ==/oat/arm64/base.odex (offset 0x43000)



Steps To ReproduceWe've been unable to reproduce this internally. It seems to be a rare issue reported by end-users.
Additional InformationThis happens when a user attempts to sign in on a device using the extension. Attempts by users to fix this issue are hampered by RunnerJNILib.OnLoginSuccess being a function that they are unable to access, even in runtime cache. All that's available to the user is: public static native void OnLoginSuccess(String _Name,String _uID,String _s,String _t,String _ts,String _tk,String _sS);
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In

Activities

Fritz

2020-01-08 15:38

Manager   ~0065260

Google Play Services Extension will need updating again for the fix