View Issue Details

IDProjectCategoryView StatusLast Update
00315582.x IDE BugsCompilingPublic2020-01-20 13:55
ReporterDanAssigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.5 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031558: Compiling: Using a whole array in a for() expression is not treated as a compiler error
DescriptionUsing a whole array in a for() expression should be a compiler error saying you need to use an individual element of the array or the size of the array.

Currently, different platforms will handle this coding mistake individually:

Windows enters the loop, but bails when beyond the length of the array
HTML5 seems to go into an infinite loop and locks up your browser tab
Android does not go into the loop and so effectively silently ignores the coding error, but also means the game doesn't work as intended
Steps To Reproduce1. Run the attached sample for the platforms mentioned.
2. Observe at no time is this treated as a compiler error that you should fix your code
Repro: 100%
TagsNo tags attached.
2.x IDE Found In2.2.5.481
2.x Runtime Found In2.2.5.378
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2019-12-31 15:55

Adminstrator  

Result.png (72,329 bytes)
Result.png (72,329 bytes)
array_loop_bug.yyz (18,433 bytes)

Dan

2020-01-20 13:55

Adminstrator   ~0065311

Is apparently fixed for 2.3.0 already, according to git commit messages.