View Issue Details

IDProjectCategoryView StatusLast Update
00315522.x IDE BugsImage EditorPublic2020-02-11 12:24
ReporterDanAssigned ToSteven Campbell 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.4 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031552: Image Editor: IDE crash if you draw using the touchscreen with a Surface Pro 7 and multi-touch
DescriptionUsing a Surface Pro 7, you can crash the IDE if you touch the screen to do your drawing. The pen by itself is apparently okay, but even then if you brush the screen with your hand you can then get the crash. Note that the issue seems to rely on multiple touches at once, so scribbling on the screen with multiple fingers, etc. is required to repro.

It actually looks like the issue is touching-and-releasing something in the surrounding UI whilst also having a touch on the drawing canvas.

You get the following in your log:

[11:14:34:263(d60a)] --------------------------------------------------------------------------------
[11:14:34:293(d60a)] IDE Exception: System.OverflowException: Arithmetic operation resulted in an overflow.
   at OpenTK.Platform.Windows.WinGLNative.HandleWMPointerUp(IntPtr handle, WindowMessage message, IntPtr wParam, IntPtr lParam)
   at OpenTK.Platform.Windows.WinGLNative.WindowProcedure(IntPtr handle, WindowMessage message, IntPtr wParam, IntPtr lParam)
   at OpenTK.Platform.Windows.Functions.DispatchMessage(MSG& msg)
   at OpenTK.Platform.Windows.WinGLNative.ProcessEvents()
   at OpenTK.NativeWindow.ProcessEvents()
   at YoYoStudio.IDE.ProcessDesktops()
   at YoYoStudio.IDE.WaitForTick()
   at YoYoStudio.IDE.Run()
   at YoYoStudio.IDE.Execute(String[] _args, Int32 _initialWidth, Int32 _initialHeight)
[11:14:34:294(d60a)] --------------------------------------------------------------------------------
Steps To Reproduce1. Start GMS2 on a Surface Pro.
2. Create a new project and add a new Sprite.
3. Open the Sprite in the image Editor.
4. Start drawing using the pen, but also touch the screen with your hand.
5. IDE crashes.
Repro: Appears 100% for the customer, but need to reproduce here.
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/165211
TagsGM2KI
2.x IDE Found In2.2.4.474
2.x Runtime Found In2.2.4.374
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2019-12-30 11:27

Adminstrator  

SurfacePenIDECrash.log (576,491 bytes)