View Issue Details

IDProjectCategoryView StatusLast Update
0031528DocumentationManual ContentPublic2020-01-17 08:53
ReporterDanAssigned ToMark Alexander 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.4 
Target Version2.3.0Fixed in Version 
Summary0031528: Manual Content: Does not explicitly state using "manual" drawing functions will only draw one frame of Spine sprite
DescriptionThe manual does not explicitly state using the "manual" drawing functions will only draw the one specific frame the developer chose when it comes to Spine sprites (i.e., it is not made clear that the rest of the animation will not continue to play thereafter).

The manual is currently worded in such a way that it reads like all of the regular png functions will work just fine for manipulating the skin and it's only really if you want to modify the skeleton do you need to use the Spine specific "skeleton..." functions, so we should add clarifications onto the regular drawing function pages that they will only result in the one chosen frame of a Spine image.

(I have not checked SWF, but currently assume the same situation will affect them, so we should confirm and fix as part of this change...)
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/164647
TagsGMDKI

Activities

Mark Alexander

2020-01-17 08:53

Developer   ~0065304

A note has been added to draw_sprite, draw_sprite_ext and draw_sprite_general about this, but only for Spine sprites as we SHOULD be supporting SWF in these functions since we have no dedicated functions for those kinds of sprite (like we do for Spine).