View Issue Details

IDProjectCategoryView StatusLast Update
0031513RunnerFunctionsPublic2019-12-11 10:51
ReporterAliceAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionWon't Fix 
PlatformWindowsOS10OS Version
Product Version2.2.4 
Target VersionFixed in Version 
Summary0031513: Functions: http_post_string() returns incorrect format, breaking Chinese characters
DescriptionIssue:
When using http_post_string to retrieve data from a json file that contains Chinese characters, they would appear to be returned in an incorrect format making the decoding of the json file fail.

Please note that I have tested decoding json data containing Chinese characters from a locally stored json file and that works as expected. This would suggest that the issue is with the results of the http_post_string function and not the json decoding.

Steps To Reproduce1.Launch the IDE
2.Run the project attached to this report
3.Observe the issue
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.5.475
2.x Runtime Verified In

Activities

Alice

2019-11-20 11:50

Adminstrator  

Post_Test.yyz (25,531 bytes)

Russell Kay

2019-11-21 09:38

Manager   ~0065142

Can we check on other platforms and see if this is a cross platform issue? Thanks

Alice

2019-12-03 10:50

Adminstrator   ~0065190

Issue also appears on Mac and Android. Couldn't reproduce on HTML5 but I think that may be because of encryption.

Russell Kay

2019-12-10 13:47

Manager   ~0065203

I would have expected the JSON string returned to encode the chinese characters as unicode escape strings, they need to be encoded as UTF8 at the very least - I am not sure they are... I will investigate further.

Russell Kay

2019-12-11 10:51

Manager   ~0065204

So the problem is that the website is not returning a utf-8 string with the json - you can tell from the headers that are returned, the json_decode requires a utf-8 string, you will need to request a utf-8 return from that website (not sure if they have parameters that can request that encoding)