View Issue Details

IDProjectCategoryView StatusLast Update
0031512RunnerAndroidPublic2019-11-28 11:49
ReporterDanAssigned ToRussell Kay 
PriorityMediumSeverityA - Crash/HangReproducibilityUnable To Reproduce
Status ResolvedResolutionFixed 
PlatformAndroidOSAndroidOS Version8.1
Product Version2.2.4 
Target Version2.2.5Fixed in Version2.2.5 
Summary0031512: Android: Certain devices can show a Gamepad.java crash "(java.lang.NullPointerException)" on startup
DescriptionWe have a report that certain devices can show a Gamepad.java crash "(java.lang.NullPointerException)" on startup in Google's crash reports given to a game's dev. It looks like this static gamepad function can be called too early in the app's startup sequence.

Note that the report so far is limited to a custom firmware for rooted phones "Umx(Ultimate Mobile Experience) U683CL (U683CL), Android 8.1", which we do not support and do not have to reproduce with. However, the issue may be affecting other legitimate devices, so we should investigate if this is the cause of other developer Google crash reports.

Steps To Reproduce???
1. Start a game on one of the affected devices.
2. Observe it crashes.
Additional Informationhttp://howtoandroitroot.com/post/umx-ultimate-mobile-experience-u683cl (there are many search results on Google for this firmware, but they all ultimately end up serving this page...)
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.4.374
2.x Runtime Verified In

Activities

Russell Kay

2019-11-26 09:51

Manager   ~0065156

Possible fix in gitlab - flying a bit blind as we cannot recreate...