View Issue Details

IDProjectCategoryView StatusLast Update
00315002.x IDE BugsBuild MacPublic2019-11-28 14:50
ReporterScott DunbarAssigned ToRussell Kay 
PriorityMediumSeverityB - MajorReproducibilityUnable To Reproduce
Status ResolvedResolutionFixed 
PlatformMacOSmacOS CatalinaOS Version
Product Version2.2.4 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031500: Build Mac: Building for mac (vm or yyc) is producing a code signing error resulting in failure to build
DescriptionRunning blank GML project and compile for MacOS export, no matter if it is VM or YYC, I get failure:

System.Exception: Error codesigning .app (1):/Users/usr/GameMakerStudio2/Mac/GMS2MAC/Untitled/Untitled.app: replacing existing signature
Warning: unable to build chain to self-signed root for signer "Developer ID Application: usr (ABCDEF123456)"
/Users/usr/GameMakerStudio2/Mac/GMS2MAC/Untitled/Untitled.app: errSecInternalComponent
In subcomponent: /Users/usr/GameMakerStudio2/Mac/GMS2MAC/Untitled/Untitled.app/Contents/Frameworks/libYoYoGamepad.dylib
Steps To ReproduceUnable to reproduce the issue internally
TagsNo tags attached.
2.x IDE Found In
2.x Runtime Found In2.2.4.374
2.x IDE Verified In
2.x Runtime Verified In

Activities

Russell Kay

2019-11-19 09:13

Manager   ~0065138

Fixed in gitlab

Dan

2019-11-28 14:50

Adminstrator   ~0065182

Note that the change here would only avoid the need to fix codesigning on your extensions before doing a VM run/debug on your local machine. You would still have to correctly codesign your extensions before making your final package to distribute anyway.

(YYC will create the Xcode project and this will handle the signing anyway, so doesn't require the same change.)