View Issue Details

IDProjectCategoryView StatusLast Update
0031497Marketplace ExtensionsApple IAPsPublic2019-12-02 08:41
ReporterDanAssigned ToDavid Clarke 
PriorityHighSeverityB - MajorReproducibility100%
Status AssignedResolutionOpen 
PlatformmacOSOSmacOS High SierraOS VersionPro x64
Product Version 
Target VersionFixed in Version 
Summary0031497: Apple IAPs: macOS 10.13 / iOS 9 and older don't support the purchase-check function called by this extension
DescriptionVersions of OS X / macOS 10.8 to 10.13 (High Sierra) and iOS 9 and older do not support the function called to check for IAP purchases in our new Apple IAPs extension - https://developer.apple.com/documentation/storekit/skproduct/1615754-downloadcontentversion

The extension needs to be modified to fallback to the old function on these older OSes.

Additional info: https://forum.yoyogames.com/index.php?threads/macos-problems-with-new-2-2-4-iaps.69240/#post-411062
Steps To Reproduce1. Run our Apple IAPs test on High Sierra or older.
Additional InformationThe GMC thread above came about from https://yoyogames.zendesk.com/agent/tickets/164077, which has a little more info also.
TagsNo tags attached.
2.x Runtime Found In2.2.4.374
2.x Runtime Verified In

Activities

There are no notes attached to this issue.