View Issue Details

IDProjectCategoryView StatusLast Update
00314922.x IDE BugsGeneralPublic2019-11-15 14:50
ReporterAliceAssigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionNo Change Required 
PlatformWindows OSWindows 10OS Version
Product Version2.2.4 
Target VersionFixed in Version 
Summary0031492: Functions: Boolean variables are treated as "numbers" by is_bool() and typeof()
DescriptionIssue:
When checking a boolean variable with the functions is_bool() and typeof(), the variable is recognised as a number instead of a boolean, as you can see in the attached screenshot.

You actually have to do an expression which results in a boolean in order to get "bool" to be returned, e.g. "typeof(1==1)". However, the manual makes no mention that you can write expressions in this function, and does say it should determine the variable passed-in, as we were trying.


Expected:
Boolean variables are identified as such by these functions.
Steps To Reproduce1-Launch the IDE
2-Open the project attached
3-Run the project
4-Observe the issue
TagsNo tags attached.
2.x IDE Found In2.2.5.475
2.x Runtime Found In2.2.5.375
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2019-11-15 11:30

Adminstrator  

Functions-BoolsTreatedAsNumbers.yyz (20,478 bytes)

Russell Kay

2019-11-15 14:50

Manager   ~0065129

This is not a bug for backward compatibility reasons...