View Issue Details

IDProjectCategoryView StatusLast Update
00314802.x IDE BugsGeneralPublic2019-11-15 13:16
ReporterScott DunbarAssigned ToRussell Kay 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformOSmacOS CatalinaOS Version10.15.0/10.15.1
Product Version2.2.4 
Target Version2.2.5Fixed in Version2.2.5 
Summary0031480: General: [MacIDE] On Catalina, on first launch we request permission to have GMS2 receive keystrokes from any application
DescriptionIssue:
  On Catalina, on first launch we request permission to have GMS2 receive keystrokes from any application

Expected:
 GMS2 should not need permission to get keystrokes from other applications
Steps To Reproduce1. Unistall GMS2
2. Perform a fresh install
3. On First launch of fresh install observe permission request
Additional InformationScreenshot shows 2.3 beta build but confirmed it occurs in 2.2.4 also
TagsNo tags attached.
2.x IDE Found In2.2.4.472
2.x Runtime Found In
2.x IDE Verified InVerified fixed in 2.2.5.475
2.x Runtime Verified InVerified fixed in 2.2.5.375

Activities

Scott Dunbar

2019-11-06 15:22

Adminstrator  

keystroke.png (142,476 bytes)
keystroke.png (142,476 bytes)

Russell Kay

2019-11-08 14:48

Manager   ~0065092

looks like we should be using Local Event Monitor rather than the Event Tap API

Russell Kay

2019-11-08 17:40

Manager   ~0065093

Fixed in github

Scott Dunbar

2019-11-15 13:16

Adminstrator   ~0065128

Verified fixed in 2.2.5.475