View Issue Details

IDProjectCategoryView StatusLast Update
00314682.x IDE BugsGenerate Project ImagesPublic2019-10-30 14:53
ReporterMark AlexanderAssigned ToRussell Kay 
PriorityVery HighSeverityA - Crash/HangReproducibility<25%
Status ClosedResolutionFixed 
Product Version2.2.4 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031468: Generate Project Images: [Mac IDE] When I click to generate, GMS2 crashes with no error message
DescriptionWhile trying to use the project image generator on GMS2 for Mac it crashes with no error.
Steps To ReproduceAdd the image file and icon file supplied to the generate project images tool
Click generate
Note the IDE closes
TagsNo tags attached.
2.x IDE Found In2.2.4.472
2.x Runtime Found In2.2.4.374
2.x IDE Verified In2.2.4.474
2.x Runtime Verified In

Activities

Mark Alexander

2019-10-27 19:21

Developer  

ui.log (151,551 bytes)

Dan

2019-10-28 11:54

Adminstrator   ~0065052

Last edited: 2019-10-28 14:37

View 2 revisions

Windows IDE is fine for us.

EDIT: Scott and I just confirmed Windows is still fine using 472 - we were able to repeatedly generate images WAY more times than we can on macOS and have not reproduced any crash.

Dan

2019-10-28 13:45

Adminstrator   ~0065054

Last edited: 2019-10-28 14:07

View 3 revisions

EDIT: Just reproduced on Mojave, using the two images from above but when they are stored in 4Dan (I tried those images on Windows first). ui.log added now.

Scott and I have now reproduced a few times on Mojave and Catalina - the issue is intermittent. Just keep clicking Generate Images each time it has succeeded, and you will get the crash fairly soon.

Dan

2019-10-28 13:58

Adminstrator  

ui-2.log (14,219 bytes)

Scott Dunbar

2019-10-28 14:44

Adminstrator   ~0065057

Tested on Catalina (dan verified on Mojave)
1. Create / open a project
2. Open Generate Project images tool (tools > Generate Project Images)
3. Click Generate
4. If crash does not occur on first attempt, just click generate again (without closing dialog)

we were getting a crash consistently under 5 attempts

Russell Kay

2019-10-29 09:14

Manager   ~0065063

I think I got this one - it is in the latest red from last night - http://jenkins.yoyogames.lan:8080/job/Zeus_Red/2008/ - v9.2.1.2008 - fixed in gitlab

Dan

2019-10-29 10:52

Adminstrator   ~0065065

IDE 474+

Dan

2019-10-30 14:53

Adminstrator   ~0065074

Scott actually verified yesterday - perhaps not quite a 100% fix, or perhaps it relies on stale cache data in order to repro, as we still got a crash the first time we tried to verify, but thereafter two Macs went for around 50 attempts without another repro, so at the very least FAR better than before.