View Issue Details

IDProjectCategoryView StatusLast Update
0031457DocumentationManual ContentPublic2019-11-14 15:01
ReporterAliceAssigned ToMark Alexander 
PriorityVery LowSeverityText/TypoReproducibility100%
Status ResolvedResolutionFixed 
Product Version2.2.4 
Target Version2.3.0Fixed in Version2.3.0 
Summary0031457: Manual: Several keyboard shortcuts definitions are outdated in the manual
DescriptionIn the Manual, several keyboard shortcuts described in the shortcuts section are not working the IDE anymore or their description is inaccurate.

Please see the attached document for a full list of the affected shortcuts.
Steps To Reproduce1.Launch version 2.2.4 of the IDE
2. Try the shortcuts mentioned in the document attached
3.Observe the issue
TagsNo tags attached.

Activities

Alice

2019-10-22 11:28

Adminstrator  

Keyboard Shortcuts (1,279 bytes)
GENERAL IDE: 
- ALT + L (Not responding)
- CTRL + SHIFT + T (Not responding)
- CTRL + ALT + ENTER (Not responding)
- ALT + SHIFT + S (Not responding)
- Backspace (Not responding)
- CTRL + PageDown/PageUp ( Doesn't do "Focused window next/previous tab" but navigates between the top and the bottom of the page in Code Editors)

PATH EDITOR:
- Backspace (Not responding)
- CTRL + P (Not responding)
- CTRL + R (Not responding)

SPRITE EDITOR: 
- Backspace (Not responding)
- SHIFT + A (Shortcut is repeated twice in the documentation)

TILE SET EDITOR: 
-None of the shortcuts seem to be working...

IMAGE EDITOR:
- ESC (Not responding)
- Numberpad 9/9/3/4 (Not responding)
- B (Not responding)
- Z (Not responding)
- Y (The mirror brush tool flickers)
- SHIFT + Plus/Minus (Not responding)

ROOM EDITOR:
- CTRL + ALT + G (Opens Explorer)

TIMELINES EDITOR: 
-Backspace (Not responding)

SCRIPTS AND CODE EDITORS:
- Home (Not responding)
- End (Not responding)
- CTRL + ENTER (Not responding)
- CTRL + Up Arrow (Not responding)
- CTRL + Down Arrow (Not responding)

OBJECT EDITOR: 
-Backspace (Not responding)
- CTRL + D/V and SHIFT + Insert (Opens the create new event dropdown)
- DND: - ESC (Not responding)
	   - F9 (Selects blocks) 
Keyboard Shortcuts (1,279 bytes)

Mark Alexander

2019-10-29 08:49

Developer   ~0065061

I have reviewed the list and only a couple are actually broken (I have passed the info to CT and when the sequences update goes out it'll be reviewed), and most of them actually work. The file I've uploaded gives instructions on how to use most of them, and flags the ones that are broken or need review, as well as the ones I definitely need to remove (which I'll do just now, but won't flag the bug as solved until CT get back to me about the others).

Keyboard Shortcuts_Revised.txt (3,880 bytes)
GENERAL IDE: 
- ALT + L (Not responding)						< Broken (asking CT if it should work)
- CTRL + SHIFT + T (Not responding)					< Broken (asking CT if it should work)
- CTRL + ALT + ENTER (Not responding)				< Works. You need to have selected a window in 
								    a workspace and then pan and zoom away from
								    the window before using it, and it'll zoom you back
								    to the selected window.
- ALT + SHIFT + S (Not responding)					< Broken (asking CT if it should work)
- Backspace (Not responding)					< Works, but should be Delete in the docs
- CTRL + PageDown/PageUp ( Doesn't do "Focused window next/previous tab" but navigates between the top and the bottom of the page in Code Editors)						< Works. You need to be in a window with multiple
								    tabs, like in an object code window with various
								    event tabs open.

PATH EDITOR:
- Backspace (Not responding)					< Works but should be Delete in the docs
- CTRL + P (Not responding)						< Works. You need to pan away from the path in 
								    in the actual editor workspace then use it.
- CTRL + R (Not responding)						< Broken (asking CT if it should work)

SPRITE EDITOR: 
- Backspace (Not responding)					< Works. Should be Delete in the docs
- SHIFT + A (Shortcut is repeated twice in the documentation)		< Will fix in the docs

TILE SET EDITOR: 
-None of the shortcuts seem to be working...				< All of them seem to work except Escape, which
								    appears to be a bug. Note that the ones listed under
								    General should actually be Brush Editor (will fix in 
								    the docs). If you need specific instructions on how
								    they should be used, ping me on Teams.

IMAGE EDITOR:
- ESC (Not responding)						< Broken. (Appears to be a bug)
- Numberpad 9/9/3/4 (Not responding)				< Not meant to work anymore and will remove.
- B (Not responding)						< Works. You need to have created a custom brush first
								    using select and copy.
- Z (Not responding)						< Works. To see it in action make a custom brush that 
								    is not square or circular.
- Y (The mirror brush tool flickers)					< Works. To see it in action make a custom brush that
								    is not square or circular or has a non-repeating texture
- SHIFT + Plus/Minus (Not responding)				< Not meant to work anymore and will remove.

ROOM EDITOR:
- CTRL + ALT + G (Opens Explorer)					< Broken (asking CT if it should work)

TIMELINES EDITOR: 
-Backspace (Not responding)					< Works. Should be Delete in the docs.

SCRIPTS AND CODE EDITORS:
- Home (Not responding)						< Works, but returns the cursor to the start of the line
								    and not the entire code block.
- End (Not responding)						< Works, but returns the cursor to the end of the line
								    and not the code block.
- CTRL + ENTER (Not responding)					< Works. You need to have created a region and be on
								    the #region tag line to use it
- CTRL + Up Arrow (Not responding)					< Works. You need to have 1 or more regions defined
- CTRL + Down Arrow (Not responding)				< Works. You need to have 1 or morte region defined

OBJECT EDITOR: 
-Backspace (Not responding)					< Works. Should be Delete in the docs.
- CTRL + D/V and SHIFT + Insert (Opens the create new event dropdown)	< Works. If you try to pste or duplicate an event in the
								    same object you get the event selector since the 
								    event already exists so you are expected to paste it
								    into a different event which you select. If you copy and
								    then paste into a different object that doesn't have 								    the same event already, this window doesn't show.

- DND: - ESC (Not responding)					< Broken (Appears to be a bug)
	   - F9 (Selects blocks) 					< Broken (asking CT what it actually does as I have 
								    no idea!)

Mark Alexander

2019-10-31 10:53

Developer  

Keyboard Shortcuts_Revised_Final.txt (3,954 bytes)
GENERAL IDE: 
- ALT + L (Not responding)						< Removed as it's not used
- CTRL + SHIFT + T (Not responding)					< Removed as it's not used
- CTRL + ALT + ENTER (Not responding)				< Works. You need to have selected a window in 
								    a workspace and then pan and zoom away from
								    the window before using it, and it'll zoom you back
								    to the selected window.
- ALT + SHIFT + S (Not responding)					< Removed as it's not used
- Backspace (Not responding)					< Works, but should be Delete in the docs
- CTRL + PageDown/PageUp ( Doesn't do "Focused window next/previous tab" but navigates between the top and the bottom of the page in Code Editors)  < Works. You need to be in a window with multiple tabs, like in an object code window with various event tabs open.

PATH EDITOR:
- Backspace (Not responding)					< Works but should be Delete in the docs
- CTRL + P (Not responding)						< Works. You need to pan away from the path in 
								    in the actual editor workspace then use it.
- CTRL + R (Not responding)						< Appears to work as designed - You need to use Shift, Click and Drag to select all the path points first

SPRITE EDITOR: 
- Backspace (Not responding)					< Works. Should be Delete in the docs
- SHIFT + A (Shortcut is repeated twice in the documentation)		< Will fix in the docs

TILE SET EDITOR: 
-None of the shortcuts seem to be working...				< All of them seem to work. Note that the ones listed under
								    General should actually be Brush Editor (will fix in 
								    the docs). If you need specific instructions on how
								    they should be used, ping me on Teams.

IMAGE EDITOR:
- ESC (Not responding)						< Broken. (Appears to be a bug)
- Numberpad 9/9/3/4 (Not responding)				< Not meant to work anymore and will remove.
- B (Not responding)						< Works. You need to have created a custom brush first
								    using select and copy.
- Z (Not responding)						< Works. To see it in action make a custom brush that 
								    is not square or circular.
- Y (The mirror brush tool flickers)					< Works. To see it in action make a custom brush that
								    is not square or circular or has a non-repeating texture
- SHIFT + Plus/Minus (Not responding)				< Not meant to work anymore and will remove.

ROOM EDITOR:
- CTRL + ALT + G (Opens Explorer)					< Works, but is mislabelled and should be CTRL + G 

TIMELINES EDITOR: 
-Backspace (Not responding)					< Works. Should be Delete in the docs.

SCRIPTS AND CODE EDITORS:
- Home (Not responding)						< Works, but returns the cursor to the start of the line
								    and not the entire code block.
- End (Not responding)						< Works, but returns the cursor to the end of the line
								    and not the code block.
- CTRL + ENTER (Not responding)					< Works. You need to have created a region and be on
								    the #region tag line to use it
- CTRL + Up Arrow (Not responding)					< Works. You need to have 1 or more regions defined
- CTRL + Down Arrow (Not responding)				< Works. You need to have 1 or morte region defined

OBJECT EDITOR: 
-Backspace (Not responding)					< Works. Should be Delete in the docs.
- CTRL + D/V and SHIFT + Insert (Opens the create new event dropdown)	< Works. If you try to pste or duplicate an event in the
								    same object you get the event selector since the 
								    event already exists so you are expected to paste it
								    into a different event which you select. If you copy and
								    then paste into a different object that doesn't have
                                                                                                                       the same event already, this window doesn't show.

- DND: - ESC (Not responding)					< Works. You need to have sleected multiplce DnD blocks
	   - F9 (Selects blocks) 					< Works. Toggles a breakpoint for the selected block(s).

Mark Alexander

2019-10-31 10:54

Developer   ~0065075

Fixed. Most of the shortcuts flagged actually seem to work fine, and those that don't have either been removed or changed to reflect the actual keys that should be used. See the uploaded "Keyboard Shortcuts_Revised_Final.txt" file for full details.