View Issue Details

IDProjectCategoryView StatusLast Update
0031440RunnerHTML5Public2019-11-22 11:20
ReporterScott DunbarAssigned ToLuke Brown 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionWon't Fix 
Product Version2.2.4 
Target VersionFixed in Version 
Summary0031440: HTML5: iPadOS (13) - os_type returns os_macosx
DescriptionIssue:
With the release of iPadOS (iOS 13), iPads are now detected as Mac devices in HTML5
Steps To Reproduce1. run attached sample on HTML5
2. on ipad - open web browser and navigate to your computers IPaddress:port
3. observe that it detects macOS
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.4.366
2.x Runtime Verified In

Activities

Scott Dunbar

2019-10-16 11:13

Adminstrator  

iosdetection.yyz (909,479 bytes)

Luke Brown

2019-11-22 11:20

Developer   ~0065145

After reviewing this with Russel, we've decided not to fix this issue. The issue is caused by iPad OS 13, which caused iPads to represent themselves as Mac OS X 10.15. While there are some workarounds which sometimes will detect the difference (no Macs currently support maxTouchPoints > 1 so this could be an identifier for now, but the safari browser doesn't allow provide maxTouchPoints info) the intention from Apple is to provide the same browser experience on iPads as on Macs going forward.