View Issue Details

IDProjectCategoryView StatusLast Update
00314182.x IDE BugsWeb ServerPublic2019-10-15 11:54
ReporterScott DunbarAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSmacOS CatalinaOS Version
Product Version2.2.4 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031418: Web Server: [Mac IDE] [Catalina] Attempting to run HTML5 target will not create the web server
DescriptionAttempting to run HTML5 target from the Mac IDE will not create the web server if you're using Catalina (on Mojave it launches the web server just fine).

This appears to be because Mono runs the app as 32bit, and Catalina won't allow this.
Steps To Reproduce1. Launch GMS2 on MacIDE running Catalina
2. create a new project
3. target HTML5
4. click run
5. observe that browser is unable to connect to webserver
6. observe no web server program is running
TagsGM2KI
2.x IDE Found In2.2.4.458
2.x Runtime Found In2.2.4.364
2.x IDE Verified In2.2.4.462
2.x Runtime Verified In2.2.4.368

Activities

Scott Dunbar

2019-10-09 09:35

Adminstrator  

ui.log (610,215 bytes)

Scott Dunbar

2019-10-09 09:36

Adminstrator  

compiler.rtf (5,543 bytes)

Russell Kay

2019-10-11 10:23

Manager   ~0064962

Fixed in gitlab - webserver is now a console app

Dan

2019-10-11 15:40

Adminstrator   ~0064968

Runtime 367+

Scott Dunbar

2019-10-15 11:54

Adminstrator   ~0064986

Verifed fixed in 2.2.4.462/368.