View Issue Details

IDProjectCategoryView StatusLast Update
00314142.x IDE BugsCrash ReporterPublic2020-01-23 14:20
ReporterScott DunbarAssigned ToRussell Kay 
PriorityHighSeverityB - MajorReproducibility50%
Status ClosedResolutionFixed 
Product Version2.2.3 
Target Version2.2.5Fixed in Version2.2.5 
Summary0031414: Crash Reporter: Will sometimes close along with the IDE when a crash occurs
DescriptionIn some cases (appears to be machine/device-specific), the crash reporter will close along with the IDE when a crash occurs, because the crash-reporter is currently part of the same process as GMS2 itself. This stops users with this crash from being able to report their issue in the most effective manner.


Steps To ReproduceRepro steps currently unknown (appears to be machine/device-specific), but it is apparently 100% if your machine does reproduce the core error.

TagsNo tags attached.
2.x IDE Found In2.2.3.436
2.x Runtime Found In
2.x IDE Verified In
2.x Runtime Verified In

Activities

Russell Kay

2019-11-13 13:35

Manager   ~0065104

Fixed in github (on master-sequences)

Alice

2019-11-15 12:21

Adminstrator   ~0065125

Awaiting user feedback before closing the issue.

Dan

2020-01-23 14:20

Adminstrator   ~0065322

We do get the very odd occasion when the crash reporter crashes also on a couple of user's machines, but the crash reporter IS now a separate process and so that's a different and new issue.

Closing this one, and will open a new one when we have more info on the new reporter also crashing.