View Issue Details

IDProjectCategoryView StatusLast Update
0031412RunnerAndroid (YYC)Public2019-10-09 15:53
ReporterScott DunbarAssigned ToRussell Kay 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionNot Fixable 
PlatformAndroid YYCOSOS Version
Product Version2.2.4 
Target VersionFixed in Version 
Summary0031412: Android YYC: Building project for all architectures will fail if there are too many objects
DescriptionIssue:
 Building project for all architectures will fail if there are too many objects

Steps To Reproduce1. Import attached project
2. Set build target to android YYC
3. Ensure android options > architectures are all ticked
4. attempt to run
5. observe error during asset compiler
 
X://bin/GMAssetCompiler.exe exited with non-zero status (-1073741819)

6. delete an object
7. clear cache
8. run the project again
9. observe successful build
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.3.344
2.x Runtime Verified In

Activities

Scott Dunbar

2019-10-08 14:25

Adminstrator  

test_toolarge.yyz (5,747,232 bytes)
buildLog.txt (4,481 bytes)
"cmd"  /c subst Z: "C:\Users\scott.dunbar\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE"

elapsed time 00:00:00.2307834s for command "cmd" /c subst Z: "C:\Users\scott.dunbar\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 10/08/2019 14:20:52
"cmd"  /c subst Y: "C:\Users\scott.dunbar\AppData\Local\GameMakerStudio2\GMS2TEMP"

elapsed time 00:00:00.2518895s for command "cmd" /c subst Y: "C:\Users\scott.dunbar\AppData\Local\GameMakerStudio2\GMS2TEMP" started at 10/08/2019 14:20:52
"cmd"  /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.4.364"

elapsed time 00:00:00.2464155s for command "cmd" /c subst X: "C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.2.4.364" started at 10/08/2019 14:20:52
Saving project to: C:\Users\scott.dunbar\Documents\GameMakerStudio2\test_toolarge\test_toolarge.yyp
Loaded Macros from C:\Users\scott.dunbar\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\test_toola_8AFA76F6_E1678E9A\macros.json
Options: X:/bin\platform_setting_defaults.json
Options: C:\Users\scott.dunbar\AppData\Roaming/GameMakerStudio2\qa_48\local_settings.json
Options: C:\Users\scott.dunbar\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\test_toola_8AFA76F6_E1678E9A\targetoptions.json
Reading project file....C:\Users\scott.dunbar\Documents\GameMakerStudio2\test_toolarge
Reading project file....X:\BaseProject
Reading config delta 'C:\Users\scott.dunbar\Documents\GameMakerStudio2\test_toolarge\options\main\inherited\options_main.inherited.yy'
finished.


Release build
Options: Z:/test_toola_8AFA76F6_E1678E9A\ExtensionOptions.json
PlatformOptions
Options: Z:/test_toola_8AFA76F6_E1678E9A\PlatformOptions.json
Options: Z:/test_toola_8AFA76F6_E1678E9A\MainOptions.json
displayname
hostname
runtime
OptionsIni
PlatformOptions
Reading project file....C:\Users\scott.dunbar\Documents\GameMakerStudio2\test_toolarge
Reading project file....X:\BaseProject
Reading config delta 'C:\Users\scott.dunbar\Documents\GameMakerStudio2\test_toolarge\options\main\inherited\options_main.inherited.yy'
finished.
Compile Constants...finished.
Remove DnD...finished.
Compile Scripts...finished.
Compile Objects...finished.
Compile Timelines...finished.
Compile Triggers...finished.
Compile Rooms...finished.
Compile Extensions...finished.
Global scripts...finished.
finished.
collapsing enums.
Final Compile...finished.
Writing Chunk... GEN8
option_game_speed=60
Writing Chunk... OPTN
Writing Chunk... LANG
Writing Chunk... EXTN
Writing Chunk... SOND
Writing Chunk... AGRP
Writing Chunk... SPRT
Writing Chunk... BGND
Writing Chunk... PATH
Writing Chunk... SCPT
Writing Chunk... GLOB
Writing Chunk... SHDR
Writing Chunk... FONT
Writing Chunk... TMLN
Writing Chunk... OBJT
Writing Chunk... ROOM
Writing Chunk... DAFL
Writing Chunk... EMBI
Writing Chunk... TPAGE
Writing Chunk... TGIN
Writing Chunk... STRG
Writing Chunk... TXTR
Writing Chunk... AUDO
ClangExeLocation=C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b\toolchains\llvm\prebuilt\windows-x86_64\bin\clang++.exe
Using NDKDir = C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b
Using PlatformDir = C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b\platforms\android-28
Using ARMToolChain = C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b\toolchains\arm-linux-androideabi-4.9\prebuilt\windows-x86_64
Using X86ToolChain = C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b\toolchains\x86-4.9\prebuilt\windows-x86_64
Using ARM64ToolChain = C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b\toolchains\aarch64-linux-android-4.9\prebuilt\windows-x86_64
Using X86_64ToolChain = C:\Users\scott.dunbar\AppData\Local\Android\android-ndk-r19b\toolchains\x86_64-4.9\prebuilt\windows-x86_64
saving file Y:/test_toolarge_5A078D5_YYC\test_toolarge.droid
Android NDK: android-14 is unsupported. Using minimum supported version android-16.    
Android NDK: WARNING: APP_PLATFORM android-16 is higher than android:minSdkVersion 14 in ./AndroidManifest.xml. NDK binaries will *not* be compatible with devices older than android-16. See https://android.googlesource.com/platform/ndk/+/master/docs/user/common_problems.md for more information.    
Stats : GMA : Elapsed=66113.1926
Stats : GMA : sp=0,au=0,bk=0,pt=0,sc=0,sh=0,fo=0,tl=0,ob=104,ro=1,da=0,ex=0,ma=2,fm=0x200000000000


X://bin/GMAssetCompiler.exe exited with non-zero status (-1073741819)
buildLog.txt (4,481 bytes)

Scott Dunbar

2019-10-08 14:33

Adminstrator   ~0064928

Updated with build output.

Increasing heap size did not fix issue

Russell Kay

2019-10-09 11:57

Manager   ~0064939

This looks like a Google NDK issue it is just failing to build anything when all the architectures are selected

Russell Kay

2019-10-09 11:58

Manager   ~0064940

This is a google NDK issue not something we can fix

Dan

2019-10-09 15:53

Adminstrator   ~0064949

Closing as per the comment above.