View Issue Details

IDProjectCategoryView StatusLast Update
0031407RunnerWindows (YYC)Public2019-10-09 15:53
ReporterScott DunbarAssigned ToRussell Kay 
PriorityVery LowSeverityB - MajorReproducibility100%
Status ClosedResolutionNo Change Required 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0031407: YYC: Attached project will immediately crash on YYC without error - due to very, very large numbers
DescriptionIssue:
 Attached project will immediately crash on YYC without error - due to very, very large numbers

VM does not crash

This was reported for android yyc, but also occurs on windows yyc
Steps To Reproduce1. import project
2. build for YYC
3. observe that game never launches
4. run for vm
5. observe it runs succesfully
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.3.344
2.x Runtime Verified In

Activities

Scott Dunbar

2019-10-03 15:45

Adminstrator  

test_yyc.zip (14,399,351 bytes)

Russell Kay

2019-10-07 13:55

Manager   ~0064914

The problem here is that stack frame size is not enough this is due to the C++ code generation and the number of array assignments that are happening here.

To stop this you should consider

1) breaking up that script into multiple scripts (perhaps have one script for initialising each array)
2) replace use of [@] with [] as that will compile without the increase in stack size
3) use external data files (in included files) and then load the data into the arrays, this will be quicker and improve compile times.

Dan

2019-10-09 15:53

Adminstrator   ~0064950

Closing as per the comment above.