View Issue Details

IDProjectCategoryView StatusLast Update
0031379RunnerInput DevicesPublic2019-11-14 16:27
ReporterDanAssigned ToDavid Clarke 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionNot Fixable 
PlatformmacOSOSmacOS MojaveOS VersionPro x64
Product Version2.2.4 
Target VersionFixed in Version 
Summary0031379: Input Devices: Xbox One pads are not detected on macOS if connected via USB rather than Bluetooth
DescriptionWired Xbox One pads are not detected on macOS, whereas wireless pads connected via Bluetooth work fine. This is the same in 2.2.3 and 2.2.4, so isn't caused by our recent addition of Apple's own gamepad library - however, that library should really be fixing this.

You currently need to install a third-party driver for Xbox pads to get wired pads to work.
Steps To Reproduce1. Run any of our gamepad test projects on macOS - Mojave or Catalina, makes no difference.
2. Connect an Xbox One pad via USB.
3. Observe the game does not react at all (no async, etc.)
Repro: 100%
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.4.357
2.x Runtime Verified In

Activities

David Clarke

2019-09-26 09:38

Developer   ~0064847

This is an OS issue. The runner is not notified of the pad's existence when it is connected.

David Clarke

2019-09-26 10:28

Developer   ~0064850

As mentioned in my earlier comment, the runner is completely in the dark about the controller. Connecting a Bluetooth enabled XB1 controller to the mac via bluetooth allows the gamepad lib to pick up on the pad, but connecting either an original or bluetooth XB1 controller via a wire will not be enough to make the runner pick up on them.

I'm not sure if the macOS 10.15 will allow you to use either via a wire either. Since Apple's messaging so far has been solely about Bluetooth enabled XB1 controllers, connecting wirelessly. Their GCController API might allow it, but I'm hesistant to suggest that would mean that our lib could pick that up also.

Dan

2019-09-30 11:35

Adminstrator   ~0064878

So far, at least, no - as mentioned already above, Catalina does not detect the pad when it is wired either. Looks like Mac's only handle wireless connections without the use of an unofficial custom driver.

Dan

2019-11-14 16:27

Adminstrator   ~0065112

Closing as per the above comments.