View Issue Details

IDProjectCategoryView StatusLast Update
00313422.x IDE BugsDevice ManagerPublic2021-07-13 15:56
ReporterDanAssigned ToCoreTech 
PriorityMediumSeverityB - MajorReproducibility100%
Status ResolvedResolutionFixed 
PlatformAmazon FireOSWindows 10OS Version1903
Product Version2.2.3 
Target Version2.3.1Fixed in Version 
Summary0031342: Device Manager: Won't make connections to networked Amazon Fires because the port isn't being passed to ADB
DescriptionDevice Manager won't make connections to networked Amazon Fires because the port isn't being passed to ADB. This is leading users to think that only USB connections are supported. https://developer.amazon.com/docs/fire-tv/connecting-adb-to-device.html helped me realise that it's simply that we're not putting the port onto the adb connect command. However, the IDE won't take the port value, so you currently have to do the connection manually in ADB and then test the connection inside the IDE, as shown in the screenshot.

Expected: If the default of 5555 cannot be changed by users we should just hard-code the port in the Device Manager connection command OR if the default of 5555 can be changed by users we need to fix the text field input to allow the port part to be specified in the hostname.
Steps To Reproduce(Check with me first that the Fire TV is on, etc.)
1. Try connecting to my Amazon Fire TV at 10.36.11.234 by adding this IP in as the hostname in Device Manager.
2. Observe it fails to connect.
3. Connect to it in ADB using the same IP, but with :5555 added on the end.
4. Confirm the Fire TV now has an authentication prompt to allow your PC/Mac to connect, accept this.
5. Confirm ADB and GMS2 now work properly and say you are connected already.
Repro: 100%
TagsIDE, igor
2.x IDE Found In2.2.3.436
2.x Runtime Found In2.2.3.344
2.x IDE Verified In
2.x Runtime Verified In

Relationships

parent of 0031344 ResolvedCoreTech Build Amazon: Can't use networked Amazon Fires because the port isn't being passed to ADB 

Activities

Dan

2019-09-11 12:20

Adminstrator  

SamH

2021-07-13 15:56

Developer   ~0066203

Closing any Amazon Fire bugs.