View Issue Details

IDProjectCategoryView StatusLast Update
0031252DocumentationManual ContentPublic2019-08-20 10:59
ReporterYellowAfterlifeAssigned ToMark Alexander 
PriorityLowSeverityD - MinorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=18362
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031252: Manual Content: asset_get_index() notes that it does not work on HTML5 for scripts, but it does
Description/source/_build/3_scripting%20reference/4_gml%20reference/asset_get_index.html

"NOTE: Script names will not resolve as assets on the HTML5 target platform due to obfuscation of the final code, which may cause issues and should be taken into consideration when using the function."

This is no longer the case as of the current versions of GMS2 - it does resolve scripts correctly, as shown in the sample.
TagsDocumentation

Activities

YellowAfterlife

2019-08-07 14:12

Developer  

html5_asset_get_index_is_ok.yyz (60,534 bytes)

Mark Alexander

2019-08-19 15:26

Developer   ~0064583

Fixed.

commit f392ba295d3410d89ee0835b570bedd312113e81