View Issue Details

IDProjectCategoryView StatusLast Update
0031192RunnerFunctionsPublic2019-08-16 14:58
ReporterScott DunbarAssigned ToRussell Kay 
PriorityLowSeverityD - MinorReproducibility100%
Status ClosedResolutionWon't Fix 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0031192: Functions: Draw_self is not affected by set_draw_alpha/draw_set_alpha
DescriptionIssue:
 Using DnD set_draw_alpha or GML draw_set_alpha does not affect sprites drawn using draw_self
Steps To Reproduce1. import attached project
2. run project
3. observe that objects drawn with draw_self in DnD and GML do not have their opacities changed
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.3.344
2.x Runtime Verified In

Activities

Scott Dunbar

2019-07-17 11:02

Adminstrator  

draw_self.yyz (24,184 bytes)

Russell Kay

2019-07-18 09:39

Manager   ~0064458

This is not a bug

Dan

2019-08-16 14:58

Adminstrator   ~0064563

Closing as per the above comment - GM has always worked this way, so if we made a change now this would likely cause a LOT of games to need updating to compensate.