View Issue Details

IDProjectCategoryView StatusLast Update
0031167RunnerSteamPublic2019-08-16 15:12
ReporterDanAssigned ToRussell Kay 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionNo Change Required 
PlatformWindows VMOSWindows 10OS VersionPro x64
Product Version2.2.2 
Target VersionFixed in Version 
Summary0031167: Steam: Third-party "Steamworks_gml" extension no longer works for VM, only YYC
DescriptionWe now have a couple of reports asking why a third-party "Steamworks_gml" extension no longer works for Windows VM, only YYC. This looks like a 1.4 extension which is still in popular use today.

Currently, the belief is that the VM runner is linked using a different version of VC++ runtime to what the dll is expecting, whereas YYC will link it using whichever VC++ runtime is on the dev's machine during the build process.

The source for this extension can also be found at https://github.com/Stormchaser2018/steamworks.gml
Steps To Reproduce1. Make sure you have the Steamworks SDK installed, etc.
2. Run the attached project for Windows VM
3. You will see in-game text that the extension failed to load and in your output window you will have the line "LoadLibraryA failed with error code 127".
4. Run it for YYC instead and observe all works.
Repro: 100%
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In

Activities

Dan

2019-07-11 15:45

Adminstrator  

Steam_extension.yyz (60,746 bytes)
SteamError127.png (57,270 bytes)
SteamError127.png (57,270 bytes)

Russell Kay

2019-07-12 14:49

Manager   ~0064412

Last edited: 2019-07-12 15:00

View 3 revisions

https://stackoverflow.com/questions/14361992/dll-load-library-error-code-126 is a good place to start

it looks like it is looking for the steam_api.dll file and not finding it (looking at a Process Monitor trace of the failing VM version)
it is also looking for an rpcss.dll which it is failing to find.

YYC is also failing on my setup so I suspect an issue with the actual DLL

Russell Kay

2019-07-12 16:04

Manager   ~0064415

I don't think this is our problem

Dan

2019-08-16 15:06

Adminstrator   ~0064566

Closing as per the above comment. Note also that we *have* made a change for 2.2.4 which will ensure that the correct Steamworks dll is being used on VM, which may also fix this if it was on us.

YellowAfterlife

2019-08-16 15:12

Developer   ~0064567

Indeed, that was due to https://bugs.yoyogames.com/view.php?id=31203 - while the original build of the extension used 1.35a (and continued to function as normal), issue author compiled it against 1.42 (as GMS2 doc suggested), which broke because VM would use 1.35a instead of the DLL from specified SDK.