View Issue Details

IDProjectCategoryView StatusLast Update
00311662.x IDE BugsGeneralPublic2019-09-13 11:02
ReporterMatthew McInnesAssigned ToDavid Clarke 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031166: General: Upon preforming a fresh install, UI.log is not written out on first launch of the IDE
DescriptionISSUE:

- Upon preforming a fresh install, UI.log is not written out on first launch of the IDE

EXPECTED:

- UI.log should be written out on first launch of the IDE
Steps To Reproduce1) Remove current installation of GMS2 and remove any %AppData% / ProgramData / Program Files related directories
2) Install latest green
3) Wait for install to finish, and first launch to occur
4) Go to ProgramData > GMS2
5) Observe no ui.log
6) Close the IDE and relaunch
7) Observe ui.log
TagsIDE
2.x IDE Found In2.2.3.431
2.x Runtime Found In2.2.3.341
2.x IDE Verified In9.2.1.1950
2.x Runtime Verified In9.9.1.1535

Activities

David Clarke

2019-08-21 09:50

Developer   ~0064600

First attempt to reproduce this failed, I observed this working correctly. I stepped through the code whilst it was running a second time, after clearing all my caches again and noticed it working fine with no obvious tells as to why it wouldn't work.

Is there something custom about the set up that reproduced this bug?

David Clarke

2019-08-21 12:56

Developer   ~0064606

I was able to reproduce when I deleted the directories and not just the contents within, as was described in the repro steps. That lead me to observe that there were in fact several exceptions being thrown because the C:\ProgramData\GameMaker... folder was being accessed before it even existed. So in this instance I've ensured that folder is created before the log file is attempted to be accessed/written to/read from.

Matthew McInnes

2019-08-22 12:07

Developer   ~0064613

Closing. Verified as fixed in:

IDE v9.2.1.1950 Runtime v9.9.1.1535