View Issue Details

IDProjectCategoryView StatusLast Update
0031163RunnerFunctionsPublic2019-09-06 17:20
ReporterStewart BishopAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031163: Functions: We don't support writing buffer_f16
DescriptionWithin the runner we have no support for these constants and converting from a float 32 to either of these is inefficient so we should remove these constants and update the documentation to match.
Steps To Reproduce1) Create a project
2) Create a buffer
3) Attempt to write a float 16 or 64 to the buffer
4) See that this has done nothing
5) Check the runner code and see there's no code to handle these
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.3.344
2.x Runtime Verified In9.9.1.1531

Activities

YellowAfterlife

2019-07-11 14:56

Developer   ~0064403

buffer_f64 definitely works, that's one of the most common types to use.

However, to note, it could be nice to rename buffer_u64 to buffer_s64 because it's being cast to signed 64-bit on read anyway.

Russell Kay

2019-07-12 14:08

Manager   ~0064409

Last edited: 2019-08-16 15:08

View 2 revisions

Fixed in gitlab -
added the f16 in properly, so we do actually support it now.
f64 is already supported (it is a double).
no plans to change the u64 name just yet.