View Issue Details

IDProjectCategoryView StatusLast Update
0031162RunnerObjectsPublic2019-07-19 10:44
ReporterDanAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionNo Change Required 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.3 
Target VersionFixed in Version 
Summary0031162: Objects: instance_create() after room_goto() won't do the Create event, but will still fire other events when the room ends
DescriptionObjects: instance_create() after room_goto() won't do the Create event for that new instance as we know the room change has been called, but it will still fire other events (such as Clean up or Room End) when the room ends and the instance is destroyed. This can then cause unexpected code error dialogs for variables not existing, etc.

room_goto(room1)
instance_create_depth(0, 0, 0, obj_spawnee);

However, you can simply swap the two lines of code around and all will be well.

instance_create_depth(0, 0, 0, obj_spawnee);
room_goto(room1)
Steps To Reproduce1. Run the attached sample.
2. Observe it throws a code error when changing to the second room
Repro: 100%
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.3.341
2.x Runtime Verified In

Activities

Dan

2019-07-11 10:30

Adminstrator  

room_goto_bug.yyz (15,057 bytes)

Russell Kay

2019-07-12 09:48

Manager   ~0064406

this is not a bug, this how GameMaker works

Dan

2019-07-19 10:44

Adminstrator   ~0064467

Closing as per the above comment.