View Issue Details

IDProjectCategoryView StatusLast Update
0031160RunnerHTML5Public2019-08-19 10:20
ReporterDanAssigned ToLuke Brown 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSWindows 10OS VersionPro x64
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031160: HTML5: skeleton_animation_get_frame() doesn't work properly, always returns 0
DescriptionAs you can see from the attached sample, skeleton_animation_get_frame() doesn't work properly on HTML5 and instead always returns 0. It does work correctly on native platforms.
Steps To Reproduce1. Run the attached sample on HTML5.
2. Observe the text in-game is stuck on 0.
3. (Optional) Run the project on Windows and observe the text in-game actually changes with the animation.
Repro: 100%
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.3.341
2.x Runtime Verified In9.9.1.1531

Activities

Dan

2019-07-11 10:07

Adminstrator  

FrameNotWorking.yyz (18,090 bytes)

Luke Brown

2019-07-12 15:32

Developer   ~0064413

fixed in gitlab. Fix involved changing variable being accessed from "time" to "trackTime" (most likely due to a spine runtime update at somepoint as "time" was commented out in the cpp runner). Fixed another instance where this old variable id was used which can be tested by using the "skeleton_animation_set_frame" gml function.