View Issue Details

IDProjectCategoryView StatusLast Update
00311462.x IDE BugsMarketplacePublic2019-09-27 09:25
ReporterStewart BishopAssigned ToFritz 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.3 
Target Version2.2.3Fixed in Version2.2.3 
Summary0031146: Marketplace: Importing specific assets fails with "'Could not find Zip file Directory at the end of the file."
DescriptionWith the update to 2.2.3 some asset packages that are being imported from the marketplace are failing due to the error:

Error extracting package archive: 'Could not find Zip file Directory at the end of the file. File may be corrupted.'

Which is a SharpCompress.Common.ArchiveException, this doesn't happen using the 2.2.2 IDE so this looks like something has changed to cause this.
Steps To Reproduce1) Open the Marketplace
2) Add GMPython to your account
3) Using the 2.2.3 IDE open your My Library
4) Download GMPython and attempt to Import it
5) See that this fails with the above exception
TagsNo tags attached.
2.x IDE Found In2.2.3.433
2.x Runtime Found In2.2.3.341
2.x IDE Verified In2.2.3.436
2.x Runtime Verified In

Activities

Dan

2019-07-08 17:02

Adminstrator   ~0064374

https://forum.yoyogames.com/index.php?threads/gms2-asset-uploader-broken-asset-became-corrupted-getting-crap-reviews.65180/#post-390272 is in part this issue also

Dan

2019-08-16 14:51

Adminstrator   ~0064560

Was all good at the time of the hotfix, but no-one had closed the report. Closing now.