View Issue Details

IDProjectCategoryView StatusLast Update
0031124RunnerSocialPublic2019-08-30 11:34
ReporterScott DunbarAssigned ToDavid Clarke 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformiOSOSiOSOS Version
Product Version2.2.2 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031124: Social: achievement_load_leaderboard() does not work properly on Game Center
DescriptionIssue:
 When attempting to use achievement_load_leaderboard to pull out game center leaderboards it will produce the following error in xcode:

Error retrieving leaderboard: Error Domain=GKErrorDomain Code=17 "The requested operations could not be completed because one or more parameters are invalid." UserInfo={GKServerStatusCode=5053, NSLocalizedDescription=The requested operations could not be completed because one or more parameters are invalid., NSUnderlyingError=0x2839af1e0 {Error Domain=GKServerErrorDomain Code=5053 "status = 5053, asking for legacy aggregate leaderboard on a game with no legacy aggregate leaderboard" UserInfo={GKServerStatusCode=5053, NSLocalizedFailureReason=status = 5053, asking for legacy aggregate leaderboard on a game with no legacy aggregate leaderboard}}}


Steps To Reproduce1. import attached project
2. run project on ios
3. observe error in output/xcode console
Tagsios, Runner
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In 2.2.4.348

Activities

David Clarke

2019-08-21 11:54

Developer   ~0064605

Reviewed the code that was present, and have made changes to ensure that the provided leaderboard ID is being used on the correct parameter. This change should cover iOS 7 and upward, as well as tvOS 9 and upward.

Scott Dunbar

2019-08-26 15:44

Adminstrator   ~0064656

Verified fixed in
IDE 2.2.4.441
Runtime 2.2.4.348