View Issue Details

IDProjectCategoryView StatusLast Update
0031120Marketplace ExtensionsGoogle Play ServicesPublic2019-08-16 15:46
ReporterStewart BishopAssigned ToFritz 
PriorityMediumSeverityB - MajorReproducibility100%
Status ResolvedResolutionFixed 
Summary0031120: Google Play Services: Unable to compile if you have Lint enabled and other Google extensions in your project
DescriptionIf you have the Google Play Services extension with the Google Play Licensing extension for example then try to compile whilst Lint is enabled you'll receive the following error:

../../build.gradle: All com.google.android.gms libraries must use the exact same version specification (mixing versions can lead to runtime crashes). Found versions 17.2.1, 16.3.0, 16.0.1, 16.0.0. Examples include com.google.android.gms:play-services-ads:17.2.1 and com.google.android.gms:play-services-measurement-sdk-api:16.3.0
Steps To Reproduce1) Open our Google Play Services project
2) Enable Lint
3) Run it
4) See that this fails
TagsExtension

Activities

Fritz

2019-08-16 14:52

Manager   ~0064561

GPS extension now breaks due to the androidx changes, but compiles fine if you remove the
import android.support.v4.app.FragmentActivity; and
import android.support.v4.app.FragmentManager;

from GooglePlayServicesExtension.java

Dan

2019-08-16 15:46

Adminstrator   ~0064570

^ v3.1.6 of the asset with current red