View Issue Details

IDProjectCategoryView StatusLast Update
0031117RunnerBuffersPublic2019-08-19 12:12
ReporterDanAssigned ToRussell Kay 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS VersionPro x64
Product Version2.2.2 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031117: Buffers: buffer_compress() appears to cause a memory leak the size of the source buffer
DescriptionAs you can see in the attached sample, buffer_compress() appears to cause a memory leak the size of the source buffer. I have reproduced the issue and then sat and watched the memory usage in the debugger for about 10 mins, and the amount of RAM used did not drop.

Have also tried the theory on the GMC thread that this is caused by making, compressing and deleting the buffer all in one step, but splitting the delete part off into an alarm and firing this later does not change the results.
Steps To Reproduce1. Run the attached sample in the debugger for Windows VM.
2. Observe the RAM usage starts at about 8.5MB.
3. Press and release the spacebar and observe it jumps by about 1MB each time you do this and does not go back down again.
Repro: 100%
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/157692

https://forum.yoyogames.com/index.php?threads/does-buffer_compress-cause-memory-leak.62999/
TagsRunner
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In9.9.1.1531

Activities

Dan

2019-07-01 15:32

Adminstrator  

buffer_compress_memory_leak.yyz (17,902 bytes)

Russell Kay

2019-07-08 15:21

Manager   ~0064370

Fixed in gitlab