View Issue Details

IDProjectCategoryView StatusLast Update
0031106RunnerParticlesPublic2019-06-28 09:37
ReporterDanAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status AssignedResolutionOpen 
Platform-OSWindows 10OS VersionPro x64
Product Version2.2.2 
Target VersionFixed in Version 
Summary0031106: Particles: Calling game_load() breaks effect_...() functions, no particles are rendered
DescriptionAs you can see from the attached sample, calling game_load() breaks effect_...() functions and no particles are rendered thereafter. Clicking the game window to set focus again after the Explorer dialog, clicking on and off the game, etc., will not fix.

This might simply be some incorrect value in the save file, but as this is binary I cannot confirm.

Note it's only the game_load() bit (steps 5 and 6 below) which are required to reproduce - you can load the save file I have attached if you want.
Steps To Reproduce1. Run the attached sample.
2. Mouse over the pink square to start the two effects.
3. LMB the square and save your file to some easy to reach place (not the default it suggests).
4. Observe particles are still working.
5. RMB the squire and select the save file off disk again.
6. Observe particles no longer work, even though otherwise the game is responding fine.
Repro: 100%
Additional Informationhttps://yoyogames.zendesk.com/agent/tickets/159410
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In

Activities

Dan

2019-06-27 17:25

Adminstrator  

test.sav (55,078 bytes)
ParticulasSimples.yyz (23,436 bytes)