View Issue Details

IDProjectCategoryView StatusLast Update
0031072RunnerHTML5Public2019-08-19 09:59
ReporterDanAssigned ToLuke Brown 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSWindows 10OS VersionPro x64
Product Version2.2.2 
Target Version2.2.4Fixed in Version2.2.4 
Summary0031072: HTML5: date_valid_datetime() says dates older than Jan 1 1970 are valid, differs from Windows
DescriptionOn HTML5, date_valid_datetime() says all dates older than Jan 1 1970 are valid, which differs from Windows and also what the manual says this function if intended to do:

"Note that this function will only consider a valid datetime as being after 1/1/1970 and anything before that will return false, so the earliest you can check would be:
date_valid_datetime(1970, 01, 01, 0, 0, 0);"
Steps To Reproduce1. Import and run the attached sample for HTML5.
2. Observe it tells you in red text that the two old dates have been considered valid.
3. (Optional) Run on Windows and observe you get white text saying all is well.
Repro: 100%
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In9.9.1.1531

Activities

Dan

2019-06-21 12:06

Adminstrator  

gmtest-date_valid_datetime.yyz (20,507 bytes)

Luke Brown

2019-06-25 09:50

Developer   ~0064265

fixed in gitlab