View Issue Details

IDProjectCategoryView StatusLast Update
00310592.x IDE BugsGeneralPublic2019-10-09 11:23
ReporterStewart BishopAssigned ToRussell Kay 
PriorityVery HighSeverityCritical BlockerReproducibility100%
Status ClosedResolutionFixed 
PlatformOSmacOS CatalinaOS Version
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0031059: General: Mac IDE crashes on startup on macOS Catalina beta or if you installed Apple's mistaken Xcode update on Mojave
DescriptionIf you open the Mac IDE then it will crash instantly when using Catalina with the following exception:

[11:54:07:97(5733)] Getting system fonts
[11:54:07:166(5733)] --------------------------------------------------------------------------------
[11:54:07:167(5733)] IDE Exception: System.NullReferenceException
[11:54:07:167(5733)] Exception message: Object reference not set to an instance of an object
[11:54:07:175(5733)] Exception stack: at (wrapper managed-to-native) OpenTK.Platform.MacOS.MacOSFactory.CFBooleanGetValue(intptr)
  at OpenTK.Platform.MacOS.MacOSFactory.GetSystemFonts () [0x000cb] in /Users/Shared/Jenkins/Home/ZeusBase/ZeusGreen/YoYoStudio/IDE/OpenTK/Platform/MacOS/MacOSFactory.cs:333
  at OpenTK.Platform.Factory.GetSystemFonts () [0x00000] in /Users/Shared/Jenkins/Home/ZeusBase/ZeusGreen/YoYoStudio/IDE/OpenTK/Platform/Factory.cs:189
  at OpenTK.Toolkit.get_AvailableFonts () [0x00014] in /Users/Shared/Jenkins/Home/ZeusBase/ZeusGreen/YoYoStudio/IDE/OpenTK/Toolkit.cs:195
  at YoYoStudio.Graphics.SystemFontCollection.RegisterAll () [0x00019] in <760fdf9bb10049a6b8c2637a90139f03>:0
  at YoYoStudio.Graphics.SystemFontCollection.Initialise () [0x00000] in <760fdf9bb10049a6b8c2637a90139f03>:0
  at YoYoStudio.Graphics.FontManager.Initialise () [0x0004b] in <760fdf9bb10049a6b8c2637a90139f03>:0
  at YoYoStudio.Graphics.Scene.Initialise () [0x00015] in <760fdf9bb10049a6b8c2637a90139f03>:0
  at YoYoStudio.IDE.Initialise (System.String[] _args, System.Int32 _initialWidth, System.Int32 _initialHeight) [0x00299] in <c0805c6e318a4a4da29a04ad73f74b1a>:0
  at YoYoStudio.IDE.Execute (System.String[] _args, System.Int32 _initialWidth, System.Int32 _initialHeight) [0x00029] in <c0805c6e318a4a4da29a04ad73f74b1a>:0
[11:54:07:176(5733)] --------------------------------------------------------------------------------
[11:54:07:176(5733)] ####################################
[11:54:07:176(5733)] Break in FatalErrorWarning (IDE:2799)
[11:54:07:177(5733)] ####################################
[11:54:07:181(5733)] --------------------------------------------------------------------------------
[11:54:07:181(5733)] Unhandled Exception: System.NullReferenceException
[11:54:07:182(5733)] Exception message: Object reference not set to an instance of an object
[11:54:07:184(5733)] Exception stack: at YoYoStudio.Plugins.Command.execute_object (System.String _command, System.Object _focus, System.Object[] paramaters) [0x0001a] in <c0805c6e318a4a4da29a04ad73f74b1a>:0
  at YoYoStudio.Plugins.Command.execute (System.String _command, System.Object[] paramaters) [0x0000a] in <c0805c6e318a4a4da29a04ad73f74b1a>:0
  at YoYoStudio.IDE.CloseProject (System.Action _continuation, System.Boolean _requestSave) [0x0001b] in <c0805c6e318a4a4da29a04ad73f74b1a>:0
  at YoYoStudio.GUI.WindowManager.ShutdownTriggered (System.Boolean _isRequest) [0x00052] in <c0805c6e318a4a4da29a04ad73f74b1a>:0
  at YoYoStudio.AppDelegate.ApplicationShouldTerminate (AppKit.NSApplication sender) [0x00007] in <d1645680cd6b4f0c92532eae9293c8cb>:0
  at (wrapper managed-to-native) ObjCRuntime.Messaging.void_objc_msgSendSuper_IntPtr(intptr,intptr,intptr)
  at AppKit.NSApplication.Terminate (Foundation.NSObject sender) [0x00037] in /Library/Frameworks/Xamarin.Mac.framework/Versions/5.8.0.0/src/Xamarin.Mac/AppKit/NSApplication.g.cs:2413
  at YoYoStudio.AppDelegate.DidFinishLaunching (Foundation.NSNotification notification) [0x000e2] in <d1645680cd6b4f0c92532eae9293c8cb>:0
  at (wrapper managed-to-native) AppKit.NSApplication.NSApplicationMain(int,string[])
  at AppKit.NSApplication.Main (System.String[] args) [0x00040] in /Library/Frameworks/Xamarin.Mac.framework/Versions/5.8.0.0/src/Xamarin.Mac/AppKit/NSApplication.cs:100
  at YoYoStudio.MacMain.Main (System.String[] args) [0x00025] in <d1645680cd6b4f0c92532eae9293c8cb>:0
[11:54:07:184(5733)] --------------------------------------------------------------------------------
Steps To Reproduce1) Install the current Catalina Beta
2) Install GMS2
3) Run the IDE
4) Check your ui.log for the crash information
TagsIDE
2.x IDE Found In2.2.3.425
2.x Runtime Found In2.2.3.337
2.x IDE Verified In2.2.3.432
2.x Runtime Verified In2.2.3.341

Activities

Dan

2019-07-02 10:42

Adminstrator   ~0064323

Last edited: 2019-07-02 13:55

View 3 revisions

Please note that we cannot control/predict the changes Apple make in their beta versions, so we will need to wait until Apple release their getting-ready-to-release-properly "GM Candidate" version before we can reliably react to this change (who knows, they might fix it for Catalina beta 3...).

EDIT: Realised that the above crash message is the same as Mojave users get if they happened to have installed Apple's broken June 3rd Xcode command line tools update. Note that you need to be using 2.2.3 to get the above log entry - 2.2.2 seems to crash too early in the process and so your log is pretty much empty.

Russell Kay

2019-07-02 13:27

Manager   ~0064328

Fixed in github

Dan

2019-07-02 15:45

Adminstrator   ~0064336

We were unable to reproduce the Mojave issue, as Apple fixed their build tools before we could get the broken ones, but Catalina beta is now fixed. IDE 432 shows no issues starting up on either OS version, so Closing.