View Issue Details

IDProjectCategoryView StatusLast Update
0031056RunnerHTML5Public2019-10-09 11:24
ReporterStewart BishopAssigned ToLuke Brown 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.3 
Target Version2.2.3Fixed in Version2.2.3 
Summary0031056: HTML5: Gamepads don't work correctly for games run in a Chromium-based browser
DescriptionIf you run a game which uses gamepads on HTML5 for a Chromium browser such as Chrome or Opera, then this will not work correctly. If you use something like Firefox, then this will work as expected.

We need to investigate and see what has changed - if this is a bug on Chrome's end, or something we only need to document.
Steps To Reproduce1) Run this sample on HTML5 targeting Chrome
2) Move using a gamepad's left axis
3) See that this doesn't work after the first movement
4) Run the game on Firefox
5) See that this works as expected
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.3.337
2.x Runtime Verified In2.2.3.340

Activities

Stewart Bishop

2019-06-17 16:33

Developer  

JamCraft3_RobotDarkCave.yyz (28,669 bytes)

Luke Brown

2019-06-18 18:00

Developer   ~0064215

fixed in gitlab

Dan

2019-06-24 12:04

Adminstrator   ~0064252

Runtime 339+

Dan

2019-06-24 16:50

Adminstrator   ~0064260

Breaks Vivaldi, Edge and Firefox - even a completely blank project, the game can't start due to a missing semicolon on line 14065 of the game's code.

Dan

2019-06-24 16:54

Adminstrator   ~0064262

Blank project attached...

testhtml5gamepad.yyz (18,998 bytes)

Dan

2019-06-24 17:08

Adminstrator   ~0064263

Last edited: 2019-06-25 14:43

View 2 revisions

Think we found the issue - it was indeed a missing semi-colon on a line. Building again now.

6e9d86fb0330ce2b4e032b61d54174d21d5585aa

Dan

2019-06-25 14:38

Adminstrator   ~0064276

Vivaldi, Chrome, Firefox, and Edge all now work properly. Closing. IDE v2.2.3.429 Runtime v2.2.3.340