View Issue Details

IDProjectCategoryView StatusLast Update
0031034RunnerGeneralPublic2019-06-20 15:59
ReporterScott DunbarAssigned ToFritz 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0031034: General: Running project using Debug will cause the game to crash (running normally does not crash)
DescriptionIssue:
 The attached project will crash when being run in debug mode. the same project does not crash when running "normally"
Steps To Reproduce1. import P:\GMS2-Bugs\0031034-AircraftDesignerGWG.yyz
2. debug run the project
3. observe that the game will crash moments after launch
4. run the project "normally"
5. observe no crash
TagsDebugger, Runner
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In2.2.3.338

Activities

Fritz

2019-06-12 10:50

Manager   ~0064165

The problem was arising as the result of the http call was returning "404: not found" which was being passed to ds_map_destroy

This string was being converted wrongly to 0, and thus destroying a ds_map that was not intended to be destroyed (run got away with it, debug it was being used & thus threw an error) I've updated the runner to throw an error which should help track this sort of problem down.

Dan

2019-06-18 16:32

Adminstrator   ~0064200

Runtime 338+

Dan

2019-06-20 15:58

Adminstrator   ~0064229

Game now throws a debugger dialog about the code error, as mentioned above. Matches what it does in non-debug runs. Closing.

Dan

2019-06-20 15:59

Adminstrator  

proof.png (20,637 bytes)
proof.png (20,637 bytes)