View Issue Details

IDProjectCategoryView StatusLast Update
0030991RunnerHTML5Public2019-06-20 15:46
ReporterYellowAfterlifeAssigned ToRussell Kay 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSWindows 10 ProOS Version>=1703
Product Version2.2.3 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030991: HTML5: if(undefined = a) is not the same as if(undefined == a) and also a fatal error
DescriptionGML:
var a = 1;
if (undefined == a) show_debug_message("oh no");
if (undefined = a) show_debug_message("oh no??");

JS:
var gmla = 1;
if ((undefined==gmla)) {show_debug_message( "oh no" );}
if ((__yy_gml_errCheck(undefined)==__yy_gml_errCheck(gmla))) {show_debug_message( "oh no??" );}

(where __yy_gml_errCheck throws a fatal because input is undefined)

I was under the impression that this was impossible because JS was generated from AST where if (a = b) and if (a == b) are the same.
TagsCompiler, html5
1.4 Found In
2.x Runtime Found In9.9.1.1455
2.x Runtime Verified In2.2.3.338

Activities

YellowAfterlife

2019-06-01 01:18

Developer  

html5_if_undefined_setequ.yyz (19,247 bytes)

Russell Kay

2019-06-05 12:12

Manager   ~0064101

Fixed in gitlab

Dan

2019-06-18 13:46

Adminstrator   ~0064193

Runtime 338+