View Issue Details

IDProjectCategoryView StatusLast Update
0030950RunnerHTML5Public2019-08-19 12:26
ReporterYellowAfterlifeAssigned ToLuke Brown 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSWindows 10 ProOS Version>=1703
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0030950: HTML5: file_find_first() returns -1 instead of ""; file_find_next() returns nothing
DescriptionSince the usual file search implementation is along the lines of
var file = file_find_first(...);
while (file != "") {
    ... do things with file
    file = file_find_next();
}
file_find_close();

the games will usually softlock.

Furthermore, in the current red the function calls a hard failure (which does a game_end) instead of soft failure + default return value, which would have been more appropriate, as we simply cannot search for files (although iterating over LocalStorage items with same prefix would have been a possibility).
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In9.9.1.1450
2.x Runtime Verified In9.9.1.1531

Activities

YellowAfterlife

2019-05-26 20:44

Developer  

a_bug.yyz (19,214 bytes)

Luke Brown

2019-06-28 11:25

Developer   ~0064305

fixed in gitlab