View Issue Details

IDProjectCategoryView StatusLast Update
00309062.x IDE BugsSource ControlPublic2019-06-25 14:53
ReporterSteven CampbellAssigned ToSteven Campbell 
PriorityHighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030906: Source Control: GMS2 unstable dialog trying to diff a file on a newly-created local repository which has no commits
DescriptionUpon creating a new local repository and opening the commits window, if you try to double click any staged or unstaged change before any commits have been made, the IDE becomes unstable.
Steps To ReproduceCreate a new project.
Open Main Options and ensure Source Control is active.
Click Source Control -> Create Project Repository.
Click Source Control -> Commit Changes.
Double click any item in unstaged or staged changes.
See that the IDE becomes unstable.
Additional InformationThis happens because there is no head or tip commit - there is nothing to diff against. Most source control tutorials assume you perform an initial commit first before doing anything, and that protects against this issue.
TagsNo tags attached.
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In2.2.3.429
2.x Runtime Verified In2.2.3.340

Activities

Steven Campbell

2019-05-21 11:33

Manager   ~0063958

Fixed in Red IDE/GitHub Pull Request 4637
Git Id: e63c3bf1b715b4f0ba5d2436fcb65c82231e9c7a

Dan

2019-06-25 14:53

Adminstrator   ~0064280

Closing as per the above comment. This separate bug is for 2.2.4, not 2.2.3.