View Issue Details

IDProjectCategoryView StatusLast Update
00307222.x IDE BugsCompilingPublic2019-05-08 14:33
ReporterScott DunbarAssigned ToRussell Kay 
PriorityVery HighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.2.2 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030722: Compiling: [Mac IDE] Runtimes are not compatible with Mono version installed by Visual Studio for Mac 2019
DescriptionThe Mono version shipped with VS2019 has a broken certificate check function, which subsequently causes our runtime tools to fail their validity test. We are seeing customers are installing this version (even though we say we do not support it on the Required SDKs page linked-to in the release notes, etc. - https://help.yoyogames.com/hc/en-us/articles/227860547) because apparently Unity requires them to install it for their recent updates.

Expected: We add a workaround for this Mono version so our certificate check still works.


Until VS2019 updates the version it installs, we require you to either roll your Mono back to the version we install (but this will break VS2019) or you will need to wait for 2.2.3 to become available. We would recommend you do not install VS2019 at this time if you can avoid it - GMS2 does not use VS on Mac at all.
Steps To Reproduce1. Install VS2019 for Mac on your macOS machine.
2. Try building any project in GMS2.
3. Observe you get an error dialog "Missing or corrupt GameMaker build tools : 0x4F030001"
Repro: 100%
TagsGM2KI
2.x IDE Found In2.2.2.413
2.x Runtime Found In2.2.2.326
2.x IDE Verified In9.2.1.1805
2.x Runtime Verified In9.9.1.1431

Activities

Russell Kay

2019-04-22 12:27

Manager   ~0063662

Fixed in gitlab