View Issue Details

IDProjectCategoryView StatusLast Update
0030718RunnerHTML5Public2019-05-08 14:49
ReporterStewart BishopAssigned ToLuke Brown 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target Version2.2.3Fixed in Version2.2.3 
Summary0030718: HTML5: draw_sprite in Post Draw fails when sprite is far enough outside room
DescriptionThe attached example project demonstrates the issue. It is set up as follows:
1. The room size is 200x200, and the window size is set to 400x400 at runtime.
2. Automatic drawing of the application surface is disabled so that the result of the Post Draw event is visible.
3. In the Post Draw event, two 16x16 sprites (white squares) are drawn: one at position 0,223 and one at position 32,224.

On Windows, both squares are drawn.
On HTML5, only the left square is drawn.

If the room height is increased to 201, then both squares will draw on HTML5.
If the sprite height is increased to 17, then both squares will draw on HTML5.
So seemingly the number "224" at which the sprite is no longer drawn is related to both room size and sprite size.
Steps To Reproduce1) Run the sample on Windows
2) Run the sample on HTML5
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In9.9.1.1431

Activities

Stewart Bishop

2019-04-22 09:15

Adminstrator  

post_draw_test.yyz (17,805 bytes)

Luke Brown

2019-04-23 12:24

Developer   ~0063681

fixed in gitlab. Change is small but in a commonly used function so it'll be worth testing a range of more complex projects for visual issues in HTML5 caused by this change, particularly projects which make use of Pre/PostDraw and GUI