View Issue Details

IDProjectCategoryView StatusLast Update
0030712RunnerHTML5Public2019-08-19 12:28
ReporterScott DunbarAssigned ToLuke Brown 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product Version2.2.2 
Target Version2.2.4Fixed in Version2.2.4 
Summary0030712: HTML5: event_perform_object() does not work as expected in various ways
DescriptionIssue:
event_perform_object behaves differently on HTML5 than on Windows:

1. event_perform_object() only performs the main Draw Event, but will ignore all the other ones.
2. Even if the function works with the main Draw Event, it seems that the text is displayed twice, as the font looks to be bold when it is actually not the case.
3. Finally, the event_object variable does not match between Windows and HTML5. Check the debug console, Windows will return "Draw Event called from: eventsInThere" while on HTML5 it will be "Draw Event called from: object0"
Steps To Reproduce1. import attached project
2. run in windows and observe output log shows call from "eventsInThere" and the game shows all draw calls
3. run in html5 and observe that:
  - Not all draw calls are made
  - The text looks like it is being drawn over twice
4. open debug console for browser and observe the output shows calls from object0
Tagshtml5, Runner
1.4 Found In
2.x Runtime Found In2.2.2.326
2.x Runtime Verified In9.9.1.1531

Activities

Scott Dunbar

2019-04-18 11:01

Adminstrator  

drawBug.yyz (34,078 bytes)

Luke Brown

2019-06-27 15:15

Developer   ~0064299

fixed in gitlab